Office Online Server Reports Unhealthy Status

By Ashok M

Recently, I deployed the office online server 2016 on windows server 2016 for the integration with Exchange 2016. As per the Office Online server requirements, installing it on the Windows server 2016 requires Office Online Server April 2017 or later. Refer here for requirements.

I installed November 2018 version of OOS which will be available in downloads in VLSC.

  • Got the certificate from internal CA with the farm name oos.cloudexchangers.com
  • Created the farm successfully and integrated with the Exchange server 2016.
  • Note: For Exchange 2016, WacDiscoveryPoint to be updated on the MailboxServer properties. This can be done using Set-MailboxServer “EXCH2016” -WacDiscoveryEndPoint “https”//oos.cloudexchangers.com/hosting/discovery”
  • Tested the OOS functionalities in OWA and it worked perfectly fine.

Here comes the issue with OOS server. When I ran the below command to check the health of the office online server, it was reporting “Unhealthy” though the functionalities were working fine.

(Get-OfficeWebAppsFarm).machines

Checked the event viewer -> Application & Service Logs -> Microsoft Office Web Apps and found the below events,

Log Name: Microsoft Office Web Apps

Source: Office Web Apps Monitoring

Date: 7/25/2020 5:31:14 PM

Event ID: 20007

Task Category: (10002)

Level: Error

Keywords: Classic

User: N/A

Computer: OOS01.cloudexchangers.com

Description:

<?xml version=”1.0″ encoding=”utf-16″?>

<HealthReport xmlns:xsd=”http://www.w3.org/2001/XMLSchema” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>

<HealthMessage>AgentManagerWatchdog reported status for AgentManagerWatchdog in category ‘Recent Watchdog Reports’. Reported status: Machine health is Unhealthy</HealthMessage>

<Severity xsi:nil=”true” />

</HealthReport>

Log Name: Microsoft Office Web Apps

Source: Office Web Apps Monitoring

Date: 7/25/2020 5:31:19 PM

Event ID: 21383

Task Category: (1)

Level: Error

Keywords: Classic

User: N/A

Computer: OOS01.cloudexchangers.com

Description:

<?xml version=”1.0″ encoding=”utf-16″?>

<HealthReport xmlns:xsd=”http://www.w3.org/2001/XMLSchema” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”>

<HealthMessage>UlsControllerWatchdog reported status for UlsController in category ‘Verify Trace Logging’. Reported status: Likely caused by shipping osipartner outputs from somewhere other than a devmain checkpoint. Trace string is found but the format is not correct in C:\ProgramData\Microsoft\OfficeWebApps\Data\Logs\ULS. The following fields has the wrong format or content: [ Category ].</HealthMessage>

<Severity xsi:nil=”true” />

</HealthReport>

Tried the below troubleshooting steps by referring to the other articles for similar issue,

  • All the pre-requisites were installed
    • Windows Server 2016

Add-WindowsFeature Web-Server,Web-Mgmt-Tools,Web-Mgmt-Console,Web-WebServer,Web-Common-Http,Web-Default-Doc,Web-Static-Content,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Security,Web-Filtering,Web-Windows-Auth,Web-App-Dev,Web-Net-Ext45,Web-Asp-Net45,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Includes,NET-Framework-Features,NET-Framework-45-Features,NET-Framework-Core,NET-Framework-45-Core,NET-HTTP-Activation,NET-Non-HTTP-Activ,NET-WCF-HTTP-Activation45,Windows-Identity-Foundation,Server-Media-Foundation

  • NET Framework 4.5.2
  • Visual C++ Redistributable Packages for Visual Studio 2013
  • Visual C++ Redistributable for Visual Studio 2015
  • Microsoft.IdentityModel.Extention.dll
  • Certificate was proper with the hostname of the server and Farm name
  • Regional settings were set to “English (United States)”
  • NET-WCF-HTTP-Activation45 feature was installed
  • Even tried removing and re-creating the farm

February 23, 2018, update for Office Online Server 2016 (KB4011024) stated that it addresses the issue with server status is displayed as “Unhealthy” – But this was not applicable since this update is for OOS version 16.0.8471.8525. In this case, version is 16.0.10338.20039

After spending some time in research, there was a discussion on github and it was mentioned that this is a known issue with the ULS logging formatting and it has been addressed in May 2019 PU. Refer here for more information.

So, installed the KB4462169 and rebooted the server

Checked the updates and it was installed successfully

After 5-10 minutes, server status reported healthy

However, in the description of the KB itself, it has been clearly mentioned that there would be an issue with Logverbosity level after applying the May 2019 update and recommended to change the settings using the below commands,

Set-OfficeWebAppsFarm -LogVerbosity “Medium”

Restart-Service WACSM

So, I decided to do one more testing of uninstalling the May 2019 KB and install the latest update which was released in July 2020 KB4484451 instead of installing the KB which was released a year ago.

I followed the below steps,

  • Uninstalled the May 2019 KB
  • Rebooted the server
  • Ran Remove-OfficeWebAppsMachine
  • Installed the latest July 2020 update KB4484451
  • Rebooted the server
  • Created the farm using the below command,

New-OfficeWebAppsFarm -InternalURL “https://oos.cloudexchangers.com” -ExternalURL “https://oos.cloudexchangers.com ” -CertificateName “OOS Cert” -EditingEnabled

Waited for 5-10 minutes

Checked the server status and it reported healthy

Verified the installed updates and found that version number has also been updated

That’s great! Issue has been resolved.

Finally, I did another testing with by removing the updates and farm again. Re-created the farm and the server health was reporting “unhealthy”. Installed the May 2019 PU KB4462169 and then installed the July 2020 KB4484451 as well. When checked the updates, it just listed the July 2020 update with the version number and not the May 2019. So, the July update superseded the May update and resolved the issue as well. I spent enough time for research and repro to arrive at this solution. I would suggest installing the latest updates for any MS product as per the Microsoft recommendations though it did not mention addressing the specific issue you are experiencing. If still the issue happens, then spend time for research and investigation.

Happy learning!! 🙂

About Ashok M

Microsoft Certified Professional with key technical skills including Microsoft Exchange, Windows Server, Microsoft Azure, Office 365, Intune, EMS, Skype for Business, Active Directory, ADFS and has got more exposure to Hyper V, System Center Configuration Manager, Virtualization, Video conferencing room systems, SQL. Have experience in design, implementation, migration &amp; support for various Microsoft infrastructure products. Currently working as "Implementation Engineer" with the UAE's first tier IV Data Center design certification in the region.

Related articles

Leave a Reply